カテゴリー
初心者さん質問掲示板

E002 -Blog トップ画面上部のリボンがリンク切れ

ご利用のテンプレート:E002 -Blog 
ご利用のサーバー:GMO
お客様のスキル:「HTML・CSSくらいなら編集できる」
ご質問内容:top画面上部の3つの窓の上にあるリボン画像がリンク切れになります。対応方法を教えてください。

「E002 -Blog トップ画面上部のリボンがリンク切れ」への6件の返信

お世話になっております。

画像がリンク切れになる場合で考えられるのは、

1. WordPressをルートディレクトリでなく、別ディレクトリにインストールした時。
2. 相性の悪いプラグインやスクリプトを導入して、プログラムが競合してしまっている時。

の2つのどちらかが多いです。

1.は初心者の方がよくやってしまいがちです。
別ディレクトリにインストールするのは簡単なのですが、
インストールした後にある設定を行わないときちんと動作しなかったり、画像が表示されません。
別のディレクトリにwordpressを設置すると、
プログラム自体のパスが変わってしまう状態になるので、
画像などが表示されなくなります。

設定方法は何種類かあるのですが、一般的なのは下記の2種類です。

● wordpress管理画面の設定でパスを指定する
● index.phpの移動と.htaccessファイルのコードの書き込み

上記のどちらかになります。

参考サイトを載せておきます。
弊社のサイトではありませんが、わかりやすいと思います。

参考サイト → http://www.uesei.com/sns_blog/wordpress_directory

別ディレクトリにインストールしたのではなく、
ドメイン直下にwordpress本体を置いてるのに画像が表示されない、
という場合は、2.が原因のことが多いです。

たいていの場合はプラグインのアンインストールで解決します。

あと、「元々は別のテンプレート(テーマ)を使っていて、後からE002に切り替えた」
という場合は、下記が原因の場合も考えられます。一度参考にしてください。
http://forum.edgeplus1template.space/question/%E4%BB%A5%E5%89%8D%E3%81%8B%E3%82%89%E9%81%8B%E5%96%B6%E3%81%97%E3%81%A6%E3%81%84%E3%81%9F%E3%82%B5%E3%82%A4%E3%83%88%E3%81%AE%E3%83%86%E3%83%BC%E3%83%9E%E3%82%92%E5%A4%89%E6%9B%B4%E3%81%97%E3%81%9F/

ワードプレスは直下に本体を置いています。

プラグインも一度全てを削除しました。

また、一旦wordpressをインストールしなおし、テンプレートも再度アップロードしたのですがリンク切れが直りません。

ロリポップでテストドメインにwordpressをインストールしてテーマをアップロードすると問題なくリボンがついています。

GMOで別ドメインにテーマをアップロードすると、リンク切れになります。

E003同様GMO系では相性が悪いのでしょうか?

お世話になっております。

他のサーバーではちゃんと画像が表示されるのですね。
「GMOサーバーが悪い!」とも言いたくはないのですが、
実際のところ、他のサーバーでE002を使っていても、
画像が表示されないといった現象は、今のところ全くでていません。
他の方も画像が表示されないといった現象を相談される方がいませんでした。

一件だけあったのですが、
それはWordPressをルートディレクトリでなく、
別ディレクトリにインストールして、
そのあとの設定が完了していなかった時に
画像が表示されなくなったという事はありました。

サーバーもいろいろな会社さんのサーバーがあるのですが、
アフィリエイターさん達みなさんがよく使ってるサーバーがいいのかもしれません。
みなさんが使ってるということは、
それなりに使いやすく安定してるということでもあるのだと思います。

最初は長期契約をせず、
まず数ヶ月間使ってみて、「良いサーバーで使いやすいな」と思ったときに、
長期契約をするのがいいかもしれません。

お世話になります。

追記です。

> 一旦wordpressをインストールしなおし、テンプレートも再度アップロードしたのですが

とありましたが、wordpressをインストールしなおしても、
同じデータベースを使っていたのでしたらあまり意味がありません。

wordpressテーマやプラグインの設定情報がデータベースに書き込まれているので、
wordpress本体やテーマ、プラグイン等をアンインストールしても
データベースにはデータが残っている状態になります。

もし、サーバーを空っぽの状態にしたいのであれば、
ドメイン直下のファイルをすべて削除し、
尚且つ、データベースの中のデータもすべて削除するか、
もしくは別の新しいデータベースを読み込ませてください。

もし、前の設定情報(テーマやプラグインの設定情報のデータ)が悪影響になっていて、
画像が表示されないのだとしたら、
新しいデータベースで構築すれば画像が表示されると思います。

その方法でもダメだとしたら、レンタルサーバーがあまりよくないのかもしれません。

お世話になっております。

他のサーバーではちゃんと動作するのに、
GMOサーバーではうまくいかないのであれば使用しないほうがいいと思います。
他のサーバーではうまくいくようなことも、うまくいかないとなれば、
他にも後々不具合的なものが出てくるかもしれませんし・・・

数多くのサーバーがあるので、すべてのサーバーで動作確認していないのですが、
正直、GMOサーバーでは動作確認していません。

アフィリエイターさんが良く使っている大手のサーバーでは動作確認しているのと、
弊社でもいろいろなサイトを持っているので、
それらのサーバーで運営して動きをみています。

GMOさんってあまりイメージが良くないので使ってませんでした。。(個人的な意見です)

コメントを残す